В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Dashocheg43
Dashocheg43
06.09.2022 08:18 •  Информатика

Написать программу,которая бы запрашивала возраст человека и сообщала,сколько лет ему осталось до пенсии,либо что он уже пенсионер. Мужчины уходят на пенсию в 60,а женщины в 55. Написать на языке C# очень

Ответ:
vladcjdyte
vladcjdyte
14.01.2022 04:36

using System;

class Program {

 static void Main() {

   Console.Write("Введите ваш пол (м/ж): ");

   string sex = Console.ReadLine();

   Console.Write("Введите ваш возраст: ");

   int age = int.Parse(Console.ReadLine());

   if (sex == "ж"){

       if (age < 55)

           Console.WriteLine($"Вам осталось {55 - age} лет до пенсии");

       else

           Console.WriteLine($"Вы пенсионер");

   }

   if (sex == "м"){

       if (age < 60)

           Console.WriteLine($"Вам осталось {60 - age} лет до пенсии");

       else

           Console.WriteLine($"Вы пенсионер");

   }

 }

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?