В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Массив содержит значения отметок 12 учащихся класса за сам. работу. На дополнительном занятии учащиеся переписали работу и получили отметки на выше (кроме тех, кто получил 10). Составить программу, которая выводит отметки, полученные учениками первоначально и после работы над ошибками

Ответ:
Аурика1303
Аурика1303
12.01.2022 19:59

var

 i: integer;

 a: array [1..12] of integer;

begin

 for i := 1 to 12 do

   readln(a[i]);    

 writeln ('До работы над ошибками', a);

 for i := 1 to 12 do

 begin

   if a[i] <> 10 then

   a[i]:= a[i] + 1;

 end;

 writeln ('После работы над ошибками', a)

end.

Язык pascal abc

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?