В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
evseeva090601
evseeva090601
10.10.2020 23:06 •  Информатика

5. Составить программу для вычисления площади треугольника, построенного по трем точкам. Вычисление длины стороны оформить в виде функции.
Исходные данные Результат
A(0,0); B(-4,0); C(0,3) Площадь треугольника равна 6 кв.см.

Ответ:
ирина1844
ирина1844
10.01.2022 13:36

pascal

Объяснение:

var

 p, s: real;

 x1, x2, x3, y1, y2, y3: integer;

function dlina(x1, y1, x2, y2: integer):real;

begin

 dlina := sqrt(sqr(x2 - x1) + sqr(y2 - y1));

end;

begin

 Write('Введите координаты точки A: '); ReadLn(x1, y1);

 Write('Введите координаты точки B: '); ReadLn(x2, y2);

 Write('Введите координаты точки C: '); ReadLn(x3, y3);

 p := (dlina(x1,y1,x2,y2) + dlina(x2,y2,x3,y3) + dlina(x1,y1,x3,y3)) / 2;

 s := sqrt(p*(p-dlina(x1,y1,x2,y2))*(p-dlina(x2,y2,x3,y3))*(p-dlina(x1,y1,x3,y3)));

 WriteLn('Площадь треугольника равна S = ', s:1:3);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?