В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
begemot14
begemot14
04.06.2021 02:36 •  Информатика

перевести с с++/паскаля на phyton или решить задачу!! задача:
Напишите программу , которая в последовательности натуральных чисел определяет наибольшее двузначное число, меньше 80. программа получает на вход натуральные числа , количество введенных чисел неизвесно, последовательномть чисел заканчивается числом 0. В последовательности всегда имеется двузнпчное число, меньше 80.
С++
#include

void main()
{
int i, max = 10;
while(std::cin >> i)
{
if(i == 0) break;
if(i > max && i < 80) max = i;
}
std::cout << i << endl;
}
паскаль:
begin

var a := ReadSeqIntegerWhile('Введите числа:',x -> x = 0).ToArray;

var check := 0;

foreach x: integer in a do begin

if (x < 80) and (x > 9) then

check +=1;

if (a.Count > 1000) and (x > 3000) then

exit;

end;

if check = 0 then

exit;

a.Where(x -> (x < 80) and (x > 9)).Max.Print

end.

Ответ:
DLM1
DLM1
30.11.2021 15:10

Відповідь:

int main() {

int i, max = -1;

while(std::cin >>i)

{if(i==0) break;

else if(i > max && i < 80) max = i;

}

std::cout << max << std::endl;

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?