В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
hofferson
hofferson
07.09.2021 09:20 •  Информатика

Как много смыслов в простом пожелании! Напишите программу, которая найдет все строки, в которых есть что-то доброе (достаточно проверить наличие подстроки добр), а потом выберет из них строку с наименьшей длиной. Формат ввода

Вводятся строки, пока не будет введена строка с фамилией Бэггинс.

Формат вывода

Вывести наименьшую длину строки, в которой есть что-то доброе. Если таких не оказалось, вывести 0.Торопиться некуда таким добрым утром, целый день впереди!

От них одно беспокойство и неприятности!

Еще, чего доброго, пообедать из-за них опоздаешь!

Не понимаю, что в них находят доброго.

— Доброго утра вам!

Мы тут в приключениях не нуждаемся, благодарствуйте!

Произнес Бильбо Бэггинс наконец. 38

Ответ:
mrartemartem1
mrartemartem1
03.01.2022 04:28

Python:

strings = []

string = input()

kind_lines = []

while 'Бэггинс' not in string:

   if 'добр' in string.lower(): kind_lines.append([string, len(string)])

   string = input()

if len(kind_lines) == 0:

   print(0)

else:

   kind_lines.sort(key=lambda x: x[1])

   print(kind_lines[0][1])

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?