В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Составить программу на языке Pascal для нахождения гипотенузы с и площади S прямоугольного треугольника, если известны его катеты а и в (тремя : обычная линейная программа, программа с использованием процедуры и программа с использованием функции)

Ответ:
maserdaser
maserdaser
01.01.2022 21:24

var

 a,b,s,c:real;

begin

 write('a b:');readln(a,b);

 c:=sqrt(sqr(a)+sqr(b));

 S:=a*b/2;

 writeln('c:',c,', S:',S);

end.

var

 a,b,s,c:real;

procedure Sc(var a,b:real);

 begin

   c:=sqrt(sqr(a)+sqr(b));

   S:=a*b/2;

   writeln('c:',c,', S:',S);

 end;

begin

 write('a b:');readln(a,b);

 Sc(a,b);

end.

var

 a,b,s,c:real;

function Sss(var a,b:real):real;

 begin

   Sss:=a*b/2;

 end;

function Ccc(var a,b:real):real;

 begin

   Ccc:=sqrt(sqr(a)+sqr(b));

 end;

begin

 write('a b:');readln(a,b);

 S:=Sss(a,b); c:=Ccc(a,b);

 writeln('c:',c,', S:',S);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?