В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Марі2017
Марі2017
25.05.2021 19:43 •  Информатика

70 ! надо написать программу на языке паскаль, которая вычисляет сумму: а) первых n натуральных чисел; б) квадратов первых n натуральных чисел; в) всех чётных чисел в диапазоне от 1 до n; г) всех двузначных чисел. всё это надо написать одной программой через оператора repeat. не с !

Ответ:
Jdhcb
Jdhcb
01.10.2020 13:03

program raf105;

var

 n,i,a,b,c,d,sqrt: integer;

begin

 write('Введите n: ');

 readln(n);

 repeat

   i:= i+1;

   a:= a+i;

   sqrt:= i*i;

   b:= b+sqrt;

   if i mod 2 = 0

     then c:= c+i;

   if (i >= 10) and (i <= 99)

     then d:= d+i;

 until i = n;

 writeln('а) ',a);

 writeln('б) ',b);

 writeln('в) ',c);

 writeln('г) ',d);

end.

PascalABC 3.4.2
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?