В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
катя12362
катя12362
26.05.2021 05:35 •  Информатика

Составить программу которая формирует массив из 15 случайных целых чисел из отрезка от -10 до 10. на экран вывести исходный массив и найденный результат. а) найти среднее арифметическое всех элементов массива. б) вычеслить среднее арифметическое положительных (отрицательных) элементов массива.

Ответ:
умница2423
умница2423
01.10.2020 13:04
Var
a: array [1..15] of integer;
avg, avgpol, avgotr: real;
i, k1, k2: byte;
begin 
avg := 0; avgpol := 0; avgotr := 0; 
writeln('Massiv:'); 
Randomize; 
for i:=1 to 15 do 
begin 
a[i]:=random(20)-10; 
write(a[i], ' '); 
avg:=avg + a[i]; 
if a[i] > 0 then     
begin       
avgpol := avgpol + a[i];       
inc(k1);     
end; 
if a[i] < 0 then     
begin       
avgotr := avgotr + a[i];       
inc(k2);     
end; 
end; 
avg:=avg/15; 
avgpol:= avgpol/k1; 
avgotr:= avgotr/k2; 
writeln; 
writeln('Srednee massiva = ', avg:3:2); 
writeln('Srednee polozh. elementov = ', avgpol:3:2); 
writeln('Srednee otric. elementov = ', avgotr:3:2); 
readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?