В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
DiankaTokmashova
DiankaTokmashova
27.01.2020 02:21 •  Информатика

На языке си напишите программу: С клавиатуры вводятся натуральное m и действительное x. Найти сумму (прикреплено). Если можно, то с пояснениями


На языке си напишите программу: С клавиатуры вводятся натуральное m и действительное x. Найти сумму

Ответ:
никнэйм0
никнэйм0
05.11.2021 06:00

/*Объяснять тут нечего, если у тебя есть понимание языка.

Отдельно пишем функцию для нахождения факториала, а затем просто с цикла считаем сумму.

*/

#include <stdio.h>

#include <math.h>

int factor(int N) {

int F = 1;

for (int i = 2; i <= N; i++)

 F *= i;

return F;

}

int main()

{

int m;

double x, _sum = 1.0;

scanf_s("%i %lf", &m, &x);

for (int i = 2; i <= 2 * m; i += 2) {

 _sum += pow(x, i) / factor(i);

}

printf("%lf", _sum);

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?