В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ElementalOfChaos
ElementalOfChaos
31.10.2021 01:16 •  Информатика

Напишите программу, которая вводит два целых числа и находит их произведение, пока произведение будет трехзначное число.

Ответ:
ppoppo
ppoppo
30.10.2021 23:00

Python:

for x in range(1000):

   for y in range(1000):

       product = x * y

       length = len(str(product))

       if length == 3:

           print(x, y)

       elif length > 3:

           break

0,0(0 оценок)
Ответ:
никита3447
никита3447
30.10.2021 23:00

o = int(input('Первое: '))

t = int(input('Второе: '))

p = (o * t)

lenght = len(str(p))

if lenght == 3:

   print('трехзначное произведение',p)

else:

   print('ПРОИЗВЕДЕНИЕ',p,'не является ТРЕХЗНАЧНЫМ')

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?