В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Написать программы на Pascal. 1. Написать программу, которая по двум катетам считает площадь прямоугольного треугольника.
2. Написать программу, которая по возрасту человека может определить - совершеннолетний ли он.
3. Написать программу, которая считает кол-во цифр в числе.

Ответ:
denishr06
denishr06
27.10.2021 09:30

1) var

a, b, c, S, P : real;

begin

write('Введите катет a : ');readln(a);

write('Введите катет b : ');readln(b);

c := sqrt(sqr(a)+sqr(b));

P := a + b + c;

S := (a*b)/2;

writeln('Периметр равен : ', P);

writeln('Площадь равна : ', S);

readln;

end.

2) program choice_2;

uses crt;

var year: integer;

begin

clrscr;

write(‘Ваш возраст > ‘); readln(year);

if (year > 0) and (year < 18) then

write(‘Вы не достигли совершеннолетия’)

else if (year > 17) and (year < 150) then

write(‘Вы достигли совершеннолетия’)

else write(‘Вероятно, введены неверные данные’);

readkey;

end.

3) uses crt;

Var n,m,p,k:integer;

Begin

write('n=');read(n);

m:=n;k:=0;

while m<>0 do begin

p:=m mod 10;

K:=K+1;

m:=m div 10;

end;

writeln('k=',k);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?