В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
МЯУСИМ2007
МЯУСИМ2007
27.11.2021 21:28 •  Информатика

Составьте программу, реализующую эпизод сказки: спрашивает, куда предпочитает пойти герой (налево, направо или прямо) и печатает, что его ждёт в каждом случае

Ответ:
kolazykov11
kolazykov11
25.10.2021 19:40

package nikitauser;

import java.util.Scanner;

public class Class {

 public static void main (String[] args) {  

  System.out.println("Куда Вы предпочитаете пойти?");

  try (Scanner scan = new Scanner (System.in)) {

   String a = scan.nextLine().toLowerCase();

   switch (a)

   {

   case "налево":

    System.out.println("Налево пойдёшь - себя потеряешь, коня !");

    break;

   case "направо":

    System.out.println("Направо пойдёшь - коня потеряешь, себя !");

    break;

   case "прямо":

    System.out.println("Прямо пойдёшь - и себя, и коня потеряешь!");

    break;

  default:

    System.out.println("Варианты ответа:\nналево\nнаправо\nпрямо");

    break;

//программа написана на Java 16. Варианты ответов могут быть разными - зависит от сказки ( данная строка - комментарий; можете просто удалить)

   } } } }

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?