В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Шурочек
Шурочек
01.03.2020 03:10 •  Информатика

Напишите программу, вычисляющую а) сумму n первых натуральных четных чисел;

б) произведение n первых натуральных нечетных чисел.

Ответ:
сергей1105
сергей1105
25.10.2021 10:20

program dimavdovuskin497;

type t1 = integer;

    t2 = double;

var n, i: t1;

   x, summa, pr: t2;

begin

writeln('Напишите программу, вычисляющую: а) сумму n первых натуральных четных чисел; б) произведение n первых натуральных нечетных чисел.');

writeln;

write('Введите общее количество чисел: ');

readln(n);

writeln;

summa := 0;

pr := 1;

for i := 1 to n do

begin

 write('Введите х: ');

 readln(x);

 writeln;

 if (frac(x) = 0) then

 begin

  if (frac(x/2) = 0) then summa := summa + x

   else pr := pr * x;

 end;

end;

writeln('Сумма n первых натуральных четных чисел равна ', summa : 5 : 0);

writeln;

writeln('Произведение n первых натуральных нечетных чисел равно', pr : 5 : 0);

readln;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?