Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
Alina25255
20.12.2022 11:23 •
Информатика
Составьте программу к : возвести данное число в куб,если оно чётное, и увеличить на 3, если оно-нечётное ps: pascal
Ответ:
kotik53Tv
01.10.2020 12:54
var
a: integer;
begin
writeln('Введите число: ');
read(a);
if a mod 2 <> 0 then writeln('Число нечетное: ',a+3)
else writeln('Число четное: ',a*a*a);
end.
0,0
(0 оценок)
Ответ:
muskuss12Ирада
01.10.2020 12:54
Uses crt;
var i:integer;
begin
readln(i);
if i mod 2=0 then writeln(power(i,3))
else writeln(i+3);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
nikitabelokon21
14.12.2022 14:23
Расставьте знаки арифметических операций (+, -, /, *) так, чтобы выполнилось равенство в двоичной системе: 1100 ? 11 ? 100 = 101000...
Djdjdjdjdjje
24.11.2021 03:00
1) при одновременном нажатии каких кнопок движение изображения на экране прекращается? 2)Текст занимает 120 байт памяти. Из скольких символов состоит текст? 3)Каково общее количество...
Luxky
28.05.2020 07:13
Что в этой программе не так, нужно что бы если пользователь ввёл имя Mira то выводилась надпись Моя любовь и странно почему то не выводит приглашение к вводу имени, что не так? написано...
валера4711009
20.01.2021 12:51
Напишите краткий конспект по информатике на тему: принцип работы монитора...
пацанизшараги
15.10.2022 05:35
Какова основная характеристика компьютерных сетей? Как ее определить?...
СлавноваМаша
28.02.2022 13:05
Т-Т Если не составлю программу для паскаля по этим заданиям, то рискую потерять жизнь Если вам не сложно бедному ребёнку, он будет очень благодарен вам Т-Т *плачет* (ладно, шучу,...
reyuatnrf
20.12.2021 16:11
Склавиатуры вводятся две даты. выдать сообщения правильно ,если первая введённая дата предшествует второй, и неправильно , если наоборот....
Marksensei
29.11.2022 07:00
Спрограммой! делала презентацию в powerpoint и куда то нажала, что исчезла вверху все действия с презентации. остался только слайд чуть ли ни на весь экран и появляются показ слайдов,...
MrCapuchino
03.04.2020 22:04
Каким вы представляете сапсана? подготовьте устные иллюстрации к каждой части этого рассказа...
danilbugaev728
31.01.2021 23:45
На графике зависимость проекции скорости vx тела от времени. определите ускорение тела аx. ...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
a: integer;
begin
writeln('Введите число: ');
read(a);
if a mod 2 <> 0 then writeln('Число нечетное: ',a+3)
else writeln('Число четное: ',a*a*a);
end.
var i:integer;
begin
readln(i);
if i mod 2=0 then writeln(power(i,3))
else writeln(i+3);
end.