В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
alexc123
alexc123
04.08.2022 01:23 •  Информатика

, написать программу на паскале. Цель следующая: Найти количество единиц и количество нулей во введенном натуральном числе.
Желательно использовать циклы while и repeat.

Ответ:
eugenetroyan
eugenetroyan
19.10.2021 01:20

1038 врод использовать циклы while и repeat не стал поэтому может быть неправильно

0,0(0 оценок)
Ответ:
minikotik322
minikotik322
19.10.2021 01:20

var

N, _counterZ, _counterU : integer;

begin

_counterU := 0;

_counterZ := 0;

readln(N);

while N > 0 do

   begin

   if N mod 10 = 1 then

       _counterU := _counterU + 1;

   if N mod 10 = 0 then

       _counterZ := _counterZ + 1;

   N := N div 10;

   end;

writeln('Количество единиц в числе: ', _counterU);

writeln('Количество нулей в числе: ', _counterZ);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?