В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Составить программу выводящую двумерный массив, элементами которого являются 0, а на главной диагонали стоят 2. (pascal)
решите !

Ответ:
gygfyye66363
gygfyye66363
02.10.2021 16:20

pascal. код в объяснении

Объяснение:

program mass;

const n = 6; //размер массива

var a: array[0..n, 0..n] of integer;

   i, j: integer;

begin

   for i := 0 to n do

     begin

     for j := 0 to n do

       begin

         a[i, i] := 2;

         Write(a[i, j]:4);  

       end;

       WriteLn;

     end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?