В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
margocharlip0cmwu
margocharlip0cmwu
20.07.2022 13:16 •  Информатика

С++ Составить программу нахождения значения функции, исчисляется в зависимости от значения аргумента.

Непонятно куда и во что его пихать. Это даже не функция, а непонятно что.


С++ Составить программу нахождения значения функции, исчисляется в зависимости от значения аргумента

Ответ:
linaaaaaaa11111111
linaaaaaaa11111111
02.10.2021 06:00

#include <iostream>

#include <cmath>

int main() {

 double x;

 std::cin >> x;

 if (1.0 < x <= 12.5) {

     std::cout << 3 * pow(x, -3) << std::endl;

 } else if (x > 12.5) {

     std::cout << 13.44 << std::endl;

 } else if (-15.4 <= x <= 1.0) {

     std::cout << atan(abs(x + 1)) << std::endl;

 } else {

     std::cout << 1 << std::endl;

 }

 return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?