В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Артур3009
Артур3009
06.08.2022 21:42 •  Информатика

Составьте программу с использованием условного оператора, предусмотрите вариант, когда значение будет выходить за пределы диапазона, в этом случае экран должен очищаться , выводиться подсказка и программа должна возвращаться в начало. условие для программы: cоставьте программу , которая в зависимости от азимута, показываемого стрелкой компаса, определят страны света: север юг, воcток,запад.

Ответ:
Goodsteve31
Goodsteve31
23.06.2020 20:09
{Первый вариант}

uses crt;
label 1;
var a: integer;
begin
1: write('Введите азимут в градусах: ');
readln(a);
 if a in [1..89] then writeln('Направление: северо-восток');
  if a = 90 then writeln('Направление: восток');
   if a in [91..179] then writeln('Направление: юго-восток');
    if a = 180 then writeln('Направление: юг');
     if a in [181..269] then writeln('Направление: юго-запад');
      if a = 270 then writeln('Направление: запад');
       if a in [271..359] then writeln('Направление: северо-запад');
        if a in [0,360] then writeln('Направление: север');
          if a > 360 then begin
           clrscr;
введите корректное значение.');
           goto 1;
           end;
          if a < 0 then begin
           clrscr;
введите корректное значение.');
           goto 1;
           end; 
end. 

{Второй вариант}
uses crt;
label 1;
var a: integer;
begin
1: write('Введите азимут в градусах: ');
readln(a);
case a of
 0,360:    writeln('Направление: север');
 1..89:    writeln('Направление: северо-восток');
 90:       writeln('Направление: восток');
 91..179:  writeln('Направление: юго-восток');
 181..269: writeln('Направление: юго-запад');
 270:      writeln('Направление: запад');
 271..359: writeln('Направление: северо-запад');
 end;
if a < 0 then begin
 clrscr;
введите корректное значение.');
 goto 1;
 end;
if a > 360 then begin
 clrscr;
введите корректное значение.');
 goto 1;
 end; 
end. 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?