В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
илья1947
илья1947
18.10.2020 10:52 •  Информатика

Очень Задачи необходимо написать на языке Паскаль….

2.9. Три шахматиста играют в шахматы. Известно количество очков, набранных каждым из них. Составить программу, которая определит, на сколько очков победитель оторвался от самого слабого игрока.

3.10. На склад поступают груза на машинах различной грузоподъемности. Одновременно на компьютер, обслуживающий склад, поступает информация о весе груза на каждой машине. Составить программу, определяющую количество машин, прибывших с грузом до полного заполнения склада, если известно, что склад вмещает 1000 тонн груза.

Ответ:
polinapiterskog
polinapiterskog
16.08.2021 13:30

В 2.9 нужно, как я понял, просто вычесть из кол-ва очков победителя кол-во очков самого слабого игрока.

В 3.10 - не совсем понятно как получаем данные. Вводятся вручную или уже загружены заранее? В любом случае можно сделать через цикл (для простоты напишу на питоне программу с ручным заполнением):

i = 0

while i < 1000:

   a = int(input())

   i += a

   print("Склад заполнен на ", i / 1000 * 100, "% (", i, ")")   #опционально

P.S. Паскаль не помню, извини.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?