В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

решить С++ Написать программу с функцией для распечатки в обратном
(инверсном) порядке текстовой строки, реализованной в виде символьного массива. Рассмотреть возможность использования рекурсии.

Ответ:
arsenal2108
arsenal2108
08.08.2021 11:29

/*cpp-файл с комментариями к коду в закрепе*/

#include <iostream>  

using namespace std;  

void reverse(char *str);  

void main()

{

setlocale(LC_ALL, "RU");

char str[80];

cin >> str;

reverse(str);

}

void reverse(char* str) {

if (*str)

 reverse(str + 1);

else

 return;

cout << *str;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?