В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
hewiky
hewiky
23.10.2020 16:45 •  Информатика

написать программу для c++. Дан двумерный массив целых чисел. имеются ли числа, оканчивающиеся нулем, в правом верхнем или в правом нижнем углу.

Ответ:
olga2610
olga2610
30.07.2021 07:45

#include <iostream>

#include <cmath>

   

void mas (int array[3][3]){

   for (int i(0); i!=3; i++){

       for (int j(0); j!=3; j++){

           array[i][j] = rand()%5;

       }

   }

}

void text (int array[3][3]){

   for (int i(0); i!=3; i++){

       for (int j(0); j!=3; j++){

           std::cout << array[i][j];

       }

   } std::cout << std::endl;

}

void NUUL (int array[3][3]){

   for (int i(0); i!=3; i++){

       for (int j(0); j!=3; j++){

           if (array [0][0] == 0){

               std::cout << "array[0][0] == 0" << std::endl;

           }

           else if(array[3][3] == 0){

               std::cout << "array[3][3] == 0" << std::endl;

           }

       }

   }

}

 

 

void main (){

 

   int arr[3][3];

       mas(arr);

       text(arr);

       NULL(arr);

 

 

 

   system ("pause");

}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?