В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
piiip
piiip
28.10.2022 08:32 •  Информатика

составить программу с процедурой выводящую на экран 4 горизонтальные линии из символов ''*'':1 линия -7 символов,2 линия-19 символов,3 и 4 линия любое количество символов(<80,количество символов вводить с клавиатуры).Написать в паскале

Ответ:
Azimus19
Azimus19
11.07.2021 15:58

Код программы:

procedure print(a, b:integer);

var i:integer;

begin

 for i:=1 to 7 do

   write('*');

 writeln();

  for i:=1 to 19 do

   write('*');

  writeln();

  for i:=1 to a do

   write('*');

   writeln();

  for i:=1 to b do

   write('*');

end;  

var a,b:integer;

begin

 writeln('Введите количество символов на 3 уровне(<80): ');

 readln(a);

 writeln('Введите количество символов на 4 уровне(<80): ');

 readln(b);

 if (a < 80) and (b < 80) then

     print(a,b)

 else

   writeln('Ошибка! Количество символов >= 80');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?