В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
arinuchik
arinuchik
30.08.2020 18:19 •  Информатика

с Python! Напишите программу, на вход которой непрерывно (в цикле) подаются введены пользователем данные. При введении каких-либо данных, кроме целых чисел, выводится сообщение об ошибке с генерирования исключения ValueError. Как только ввели целое число, выводится сообщение True и происходит выход из программы.

Ответ:
annagutsman
annagutsman
07.07.2021 13:25

прикрепляю файл с рабочим кодом. При желании можно в  блоке except в строке print ввести любое выражение, которое должно появляться при некорректном значении.

while True:

   x=input()

   try:

       x=int(x)

       print('True')

       break

   except ValueError:

       print('ValueError')

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?