В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Danika38
Danika38
20.08.2020 03:36 •  Информатика

Задание: "Максимум" Напишите программу, которая считывает два натуральных числа a и b и выводит наибольшее значение из них.

Можно использовать арифметические знаки (Например: *), но нельзя использовать циклы, функции, ветвления и прочее.
На Python

Ответ:
Марина6456667
Марина6456667
01.07.2021 18:53

Напишем собственную функцию:

def _max(num1, num2):

   return int(((num1//num2) * num1 + (num2//num1) * num2)/((num1//num2) + (num2//num1)))

print(_max(int(input()), int(input(

Если без функции, то:

num1, num2 = int(input()), int(input())

print(int(((num1//num2) * num1 + (num2//num1) * num2)/((num1//num2) + (num2//num1

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?