В
Все
Г
Геометрия
Д
Другие предметы
У
Українська література
Э
Экономика
Г
География
О
ОБЖ
М
Математика
Л
Литература
Х
Химия
Қ
Қазақ тiлi
М
МХК
О
Обществознание
У
Українська мова
А
Алгебра
А
Английский язык
Ф
Физика
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
Р
Русский язык
О
Окружающий мир
romanbeletsky2
romanbeletsky2
13.09.2020 03:24 •  Информатика

Напишите в питоне Алгоритм вычисления значения функции F(n), где n – натуральное число, задан следующими соотношениями:

F(n) = n, при n ≤ 3

при n > 3:

F(n) = n + F(n–1), при чётном n;

F(n) = n*n + F(n-2), при нечётном n;

Определите количество натуральных значений n, при которых F(n) меньше, чем 10^8.

Ответ:
Помрлтм245
Помрлтм245
29.06.2021 21:34

def f(n):

   if n <= 3:

       return n

   elif n % 2 == 0:

       return n + f(n - 1)

   else:

       return n*n + f(n-2)

cur = 1

while(f(cur) < 1e8):

   cur += 1

print(cur - 1)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?