В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Ксюника1
Ксюника1
13.03.2021 11:00 •  Информатика

Дан одномерный массив. Написать программу, которая находит значение максимального элемента и заменяет его на значение произведения элементов
(остальных) массива (второй массив не использовать). Программа выводит
исходные данные и измененный массив.

Ответ:
Ramaz7771
Ramaz7771
27.06.2021 13:05

Объяснение:

Python

from random import randint

n=int(input('Введите размер матрицы  :'))

a=[randint(1,20) for j in range(n)]

print(a)

m=max(a)

ind = a.index(m)

print('Максимальный элемент a[',ind,']=', m)

p=1

for i in range(n):

  if i!=ind:

     p*=a[i]

a[ind]=p

print(a)


Дан одномерный массив. Написать программу, которая находит значение максимального элемента и заменяе
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?