В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
fedosovsemen
fedosovsemen
11.03.2020 04:57 •  Информатика

Составьте программу которая заполняет массив а [1..8] случайными числами в диапазоне от 1 до 10 и выводит на экран количество элементов с чётными значениями и сумму элементов массива с нечётными значениями

Ответ:
alanada1
alanada1
23.06.2020 14:54
Var
  a : array [1..8] of integer;
  i, count, sum : integer;
begin
  randomize;
  for i := 1 to 8 do
    a[i] := random (10) + 1;
  count := 0; sum := 0;
  for i := 1 to 8 do
    if a[i] mod 2 = 0 then count := count + 1
    else sum := sum + a[i];
  writeln ('count = ', count);
  writeln ('sum = ', sum);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?