В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
dĵdjdkdkdkdkdk
dĵdjdkdkdkdkdk
11.07.2020 11:04 •  Информатика

Напишите программу в паскале и объясните, как это делается сложить два 15-ти значных целых числа. при этом используют тип integer. т.е. реализовать поэлементное сложение значений двух массивов с переносом разряда.

Ответ:
braununs
braununs
23.06.2020 12:20
Const n=15;
var a,b,c:array[0..n] of integer;
s_a,s_b:string;
i:integer;
Begin
  readln(s_a);
  readln(s_b);
  while length(s_a)<n do s_a:='0'+s_a;
  while length(s_b)<n do s_b:='0'+s_b;
 
  for i := n downto 1 do begin
    a[i]:=strtoint(s_a[i]);
    b[i]:=strtoint(s_b[i]);
    c[i]:=c[i]+a[i] + b[i];
    c[i-1]:=c[i] div 10;
    c[i]:=c[i] mod 10;
  end;

  writeln;
  for i:= 0 to n do write(a[i]);
  writeln;
  for i:= 0 to n do write(b[i]);
  writeln;
  for i:= 0 to n do write(c[i]);
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?