В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
alenaafaunova
alenaafaunova
11.02.2020 21:33 •  Информатика

Составьте программу, в которой у пользователя запрашивают шестизначное число, а затем выводят в строчку через промежутки по порядку его цифру.

Ответ:
misspsix123
misspsix123
23.06.2020 10:59

Один из примеров реализации на JS, Pascal:


Составьте программу, в которой у пользователя запрашивают шестизначное число, а затем выводят в стро
Составьте программу, в которой у пользователя запрашивают шестизначное число, а затем выводят в стро
0,0(0 оценок)
Ответ:
darjaborisenko
darjaborisenko
23.06.2020 10:59

program raf105;

var

 a:array[1..6] of integer;

 n,i: integer;

begin

 write('Введите шестизначное число: ');

 readln(n);

 a[1]:= n div 100000;

 a[2]:= (n div 10000) mod 10;

 a[3]:= (n div 1000) mod 10;

 a[4]:= (n div 100) mod 10;

 a[5]:= (n div 10) mod 10;

 a[6]:= n mod 10;

 write('Вывод: ');

 for i:= 1 to 6 do

   write(a[i],' ');

 end.

PascalABC 3.4.2
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?