В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
orynbasar2001
orynbasar2001
26.10.2021 02:50 •  Информатика

Написать программу в паскале реализующуу работу меню содержащих следующие пункты: 1 вычесление суммы цыфр числа n; 2 вывод на экран таблицы квадратов первого десятка; 3 дано число n. определить его четность; 4 выход.

Ответ:
akerkeserikbai
akerkeserikbai
23.06.2020 08:36
Program menu;
uses  crt;
var  m, i: integer; 
n, z, x, b: longint;
begin 
Writeln('Выберете пункт меню:'); 
Writeln('[1]Вычисление суммы цыфр числа N'); 
Writeln('[2]Вывод на экран таблицы квадратов первого десятка'); 
Writeln('[3]Дано число N. Определить его четность'); 
Writeln('[4]Выход'); 
read(m); 
   case m of    1:          
   begin       
   clrscr;       
   writeln('Введите число N:');       
   read(n);        
   x := 10;        
   z := n mod x;        
   while n div x > 0 do        
   begin         
   b := x;          
   x := x * 10;          
   z := z + n mod x div b;        
  end;        
  Writeln('ответ: ', z);        
  end;    
 2:            begin       
   clrscr;       
   for i := 1 to 10 do       
   begin         
   writeln('Квадрат ', i, ' = ', sqr(i));       
   end;     
   end;       
3:      begin       
    clrscr;       
    writeln('Введите число N:');       
    read(n);       
    if (n mod 2 ) = 0 then writeln('Число ', n, ' четное.') else writeln('Число ', n, ' не четное.');     
    end;       
4: exit;  end;  
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?