В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Pmogi111
Pmogi111
27.02.2020 03:52 •  Информатика

Напишите программу удаляющая из текста все буквы с его последней буквой

Ответ:
elveranasibull
elveranasibull
01.10.2020 11:40
Uses crt;
var s:string;
n,i:integer;
begin
readln(s);
n:=length(s);
for i:=1 to n do
if s[i]=s[n] then delete(s,i,1);
writeln(s);
end.

Эта программа рассчитана на то, что удаляется и последний символ тоже
0,0(0 оценок)
Ответ:
филосов00
филосов00
01.10.2020 11:40
Var s:string; i:integer;
begin
read(s);
i:=1;
while i<length(s) do
if s[i]=s[length(s)] then s:=copy(s,1,i-1)+copy(s,i+1,length(s)-i)
else i+=1;
write(s)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?