В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
123123324322221
123123324322221
07.07.2020 19:14 •  Информатика

1. написать программу для определения количества двузначных чисел в диапазоне от а до b, которые при делении на 6 остаток 2. 2. найти сумму двузначных чисел в диапазоне от а до b, в которых первая цифра ровно в 2 раза больше второй.

Ответ:
veron001
veron001
22.06.2020 00:15
1) var a,b,x:integer;
begin
write('A: ');
readln(a);
write('B: ');
readln(b);
for x:=a to b do
begin
if (x>=10) and (x<=99) then
if x mod 6 = 2 then
write(x,' ');
end;
end.

2) var a,b,x,s :integer;
begin
write('A: ');
readln(a);
write('B: ');
readln(b);
for x:=a to b do
if (x=21) or (x=42) or (x=63) or (x=84) then s:=s+x;
write(s);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?