В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
adidok199680
adidok199680
05.05.2021 02:36 •  Информатика

20.2 напишите программу которая в последовательности натуральных чисел вычисляет сумму трехзначных чисел кратных 4 программа получает на вход натуральные числа количество введённых чисел неизвестно последовательность чисел заканчивается числом 0 0 признак окончания ввода не входит в последовательность количество чисел не превышает 20 введённые числа не превышают 1500. программа должна вывести одно число: сумму трехзначных чисел, кратных четырем.​

Ответ:
rebrot40
rebrot40
01.10.2020 11:32

program raf105;

var a,sum: integer;

begin

writeln('Вводите числа по очереди');

writeln('Чтобы закончить введите 0');

repeat

 if (a >= 100) and (a <= 999) and (a mod 4 = 0)

   then sum:= sum+a;

 readln(a);

until a=0;

writeln('Сумма трёхзначных чисел кратных четырём: ',sum);

end.

PascalABC 3.4.2
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?