В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
lovemopeio
lovemopeio
07.05.2022 20:12 •  Информатика

Составить программу нахождения для заданного натурального числа всех делителей, кратных числу .формат входных данных входной файл содержит числа , формат выходных данных выведите искомые делители. примеры: вход6 3 выход3 6

Ответ:
Dasha29081
Dasha29081
21.06.2020 20:22
#include <iostream>
using namespace std;
int main()
{
    int a,b;
    cin >> a >> b;
    for (int i = 1; i <= a; i++)
    {
        if (a%i == 0)
        {
            if (i%b == 0)
            {
                cout << i << ' ';
            }
        }
    }
    system("pause");
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?