Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
Kristina162000
23.06.2021 22:27 •
Информатика
Напишите программу которая вводит натуральное число n и находит все совершенные числа в диапазоне от 1 до n pascal
Ответ:
valera242
21.06.2020 07:23
Var i, j, n, p: integer;
begin
readln(n);
for i := 1 to n do
begin
p := 0;
for j := i - 1 downto 1 do
if (i mod j = 0) then p := p + j;
if p = i then writeln(i, '- совершенное число');
end;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Kuznetsova8903
13.01.2022 07:52
У вашого двоюрідного брата скоро день народження- батьки звернулися до вас за до у створенні кошторису для проведенкя дитячого йому виповниться 7 років. Його свята....
Polinka20071
30.06.2021 13:39
Напишите код в С очень надо)...
luneix123
21.03.2020 23:27
Дано число. если оно не делится на 5, то увеличить число в 5 раз, в противном случае уменьшить число в 5 раз....
levkovich023
29.02.2020 02:31
Деректер типтері. 1-сабақ Тұжырымның ақиқат не жалған екенін анықта.Үштік апострофтар немесе тырнақшалар көп таңбадан тұратын ұзын жолды өңдеу үшін қолданылады.ЖалғанАқиқатАртқаТексеру...
valeriy3fors
07.09.2021 11:27
1. Запишите оператор ввода данных с клавиатуры. 2. Запишите оператор вывода. 3. Запишите оператор присвоения. 4. Запишите строковый тип данных. Выполни Составьте...
radvika08
26.05.2023 12:48
3. Не себепті видеоксазбаны mp4, .avi форматында сақтау 2. Неліктен видеоларға аудио осерлер кірістіреміз?Сереоін анықтадын1. Неліктен видеоларды өңдейміз?caxxcer?80...
Andriashka
06.01.2020 23:30
Array массивімен бірнеше амалды орындаңдар...
fox3221
15.02.2020 14:44
составьте программу заполнения и вывода на экран целочисленного массива а из десяти элементов, каждый из которых равен: своему индексу и квадрат инлекса...
curlyprettygirl
01.08.2022 01:15
Что такое байт сколько байтов составляет 1 килобайт...
Koul637
24.03.2021 12:55
Дан список из 7 элементов, найти произведение нечетных чисел....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
readln(n);
for i := 1 to n do
begin
p := 0;
for j := i - 1 downto 1 do
if (i mod j = 0) then p := p + j;
if p = i then writeln(i, '- совершенное число');
end;
end.