В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Kristina8478
Kristina8478
16.08.2022 20:42 •  Информатика

Решить в паскале 1. вводится число от 1 до 10. дать название этого числа (1 - один , 2 - два , …, 10 - десять); 2. вводится число от 1 до 7, определяющее день недели. дать название этого дня (1 - понедельник, 2 - вторник, …, 7 - воскресенье); 3. в спортивных соревнованиях шарик, кот матроскин, дядя фёдор и почтальон печкин заняли соответственно 1, 2, 3 и 4 места. составить программу, которая по номеру места выдаёт имя участника соревнований. 4. вводится число от 1 до 15. вывести данное число, записанное римскими цифрами (i, ii, iii, iv, v, vi, …., xv); 6. вводится число от 1 до 15. вывести данное число, записанное в двоичной системе счисления (1, 10, 11, 100, 101, …., 1111);

Ответ:
lordczar95
lordczar95
21.06.2020 06:15
Var a:integer;
begin
readln(a)
if a:=1 then writeln('1 - один');
 if a:=2 then writeln('2 - два');
 if a:=3 then writeln('3 - три');
 if a:=4 then writeln('4 - четыре');
. . .{по аналогии}
end.
2)Абсолятно то же самое что и в предыдущем номере, просто тепрь писать 1 - понедельник, 2 - вторник...
3)var a:integer;
if a:=1 then writeln('Sharik');
if a:=2 then writeln('kot');
if a:=3 then writeln('Fedor');
if a:=4 them writeln('Pechkin');
end.
4) и 6) выполняются по аналогии.
Если не понимаешь, я объясню в комментариях.
 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?