В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
alkhodzhaevaka
alkhodzhaevaka
06.11.2021 23:51 •  Информатика

:напиши цифровой фильтр. на вход программе подаётся строка символов. на выходе должны быть только её цифры. например, если на входе была строка he110, k177en! то на выходе должно быть 110177 2. в строке, состоящей из слов, разделённых одним или несколькими пробелами, вывести второе слово. например, если на вход программе подавалась строка меня истина манит сияньем то на выходе будет истина на вход подаётся строка. вывести часть входной часть строки. часть строки задаётся номером первого символа и количеством символов. var s: string; n, k, i: integer; begin readln(s, n, k); for i : = n to n+k-1 do write(s[i]); end. 2. на вход подаётся предложение на языке. вывести все гласные строки в том порядке, в котором они встречались в строке. (ключевой фрагмент) for i : = 1 to length(s) do if s[i] in ['a', 'e', 'i', 'o', 'y', 'a', 'e', 'i', 'o', 'y'] then write(s[i]); варианты программы определения, является ли строка полиндромом var s, s1: string; i: integer; begin readln(s); s1 : = ''; for i : = 1 to length(s) do s1 : = s[i] + s1; write('строка '); if s1 < > s then write('не '); writeln('является полиндромом'); end. var s: string; i, j: integer; begin readln(s); i : = 1; j : = length(s); while (i < j) and (s[i] = s[j]) do begin inc(i); dec(j); end; write('строка '); if s[i] < > s[j] then write('не '); writeln('является полиндромом'); end.

Ответ:
Tricjt
Tricjt
20.06.2020 22:51
Var a: string;
    i: integer;
begin
     readln(a);
     for i := 1 to length(a) do
         if (a[i] in ['0'..'9']) then write(a[i]);
end.

2) Тут лучше: на входе строка, а берётся часть между 1 и 2 пробелами, ответ уже есть под задачей х)
var a, b: string;
    i: integer;
    w: boolean;
begin
     readln(a);
     for i := 1 to length(a) do
     begin
         if ((a[i] = ' ')) then
            if (length(b) = 0) then w := true else w:=false;
         if (w) then b := b + a[i];
     end;
     writeln(b);
end.

3)
var s: string;
    i: integer;
begin
     readln(s);
     for i := 1 to length(s) do
     if s[i] in ['A', 'E', 'I', 'O', 'Y', 'a', 'e', 'i', 'o', 'y']
        then write(s[i]);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?