В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
markthebest95
markthebest95
08.11.2020 05:28 •  Информатика

Заполните массив с клавиатуры целыми числами и найдите сумму элементов массива с i1-го по i2-й (i1 и i2 вводить с клавиатуры). входные данные: в первой строке целое число n (0 < n ≤ 100) - кол-во элементов в массиве и целые числа i1 и i2 (0 < i1, i2 ≤ 100). во второй строке целые числа х1, разделенные пробелом (числа по модулю не превосходят 32000) - значения элементов массива. выходные данные: сумма элементов массива c номерами от i1 до i2. (написать программу на паскале)

Ответ:
Tgnbva
Tgnbva
20.06.2020 21:23
Var
 a:array [1..100] of longint;
 N,i1,i2,i,S:longint;
begin
 Read(N,i1,i2);
For i:=1 to N do Read(a[i]);
For i:=i1 to i2 do S:=S+a[i];
Write(S);
end.
0,0(0 оценок)
Ответ:
shabrikovayana
shabrikovayana
20.06.2020 21:23
За такую программу писать лень:D
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?