В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Составить программу и блок-схему, определяющую принадлежит ли точка с координатами (X, Y) множеству точек плоскости, изображенному на рисунке на языке Паскаль


Составить программу и блок-схему, определяющую принадлежит ли точка с координатами (X, Y) множеству

Ответ:
kseniya7117
kseniya7117
23.06.2021 19:59

Free Pascal

uses Classes;

var

 p: TPoint;

begin

 writeln('input X:');

 readln(p.x);

 writeln('input Y:');

 readln(p.y);

 if (sqr(p.x) + sqr(p.y) <= 25) and (p.x<=0) and (p.y>=0) then

   writeln('Yes')

 else

   writeln('No')

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?