В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
gatshow029
gatshow029
16.07.2021 04:19 •  Информатика

Написать программу в С++
Кто не знает , не пишите "я не знаю" и т.д.


Написать программу в С++ Кто не знает , не пишите я не знаю и т.д.

Ответ:
Tania1236
Tania1236
22.06.2021 16:18

#include <iostream>

using namespace std;

int main() {

 double shop1, shop2, shop3,money1, money2, money3;

 double day, max, maxday;

 cout << "Введите доход первого магазина: ";

 cin >> shop1;

 cout << "Введите доход второго магазина: ";

 cin >> shop2;

 cout << "Введите доход третего магазина: ";

 cin >> shop3;

 day = 10;

 if(shop1 < shop2 and shop2 > shop3){

     maxday = 2;

 }

 else if(shop2 < shop1 and shop1 > shop3){

     maxday = 1;

 }

 else if(shop1 < shop3 and shop3 > shop2){

     maxday = 3;

 }

 for (int i = 1; i < day; i++) {

     for (int i1 = 0; i1 <= day; i1++) {

         money1 = shop1 + money1;

     }

     for (int i2 = 0; i2 <= day; i2++) {

         money2 = shop2 + money2;

     }

     for (int i3 = 0; i3 <= day; i3++) {

         money3 = shop3 + money3;

     }

 }

 if(money1 < money2 and money2 > money3){

     max = money2;

     cout << "Максималная доход второго магазина: " << shop2 << " за "<< 1 << " ден\n";

     cout << "Максималная доход второго магазина: " << max << " за "<< day << " дней";

     return 0;

 }

 else if(money2 < money1 and money1 > money3){

     max = money1;

     cout << "Максималная доход первого магазина: " << shop1 << " за "<< 1 << " ден\n";

     cout << "Максималная доход первого магазина: " << max << " за "<< day << " дней";

     return 0;

 }

 else if(money1 < money3 and money3 > money2){

     max = money3;

     cout << "Максималная доход третего магазина: " << shop3 << " за "<< 1 << " ден\n";

     cout << "Максималная доход третего магазина: " << max << " за "<< day << " дней";

     return 0;

 }

 

}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?