В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
kir28082000
kir28082000
16.02.2023 02:50 •  Информатика

Пользователь вводит последовательность чисел. Необходимо написать программу, которая вычисляет и выводит на экран среднее арифметическое всех чисел последовательности. Программа должна прекратить запрос чисел на ввод, когда пользователь введёт слово “stop”. Цикл While python

Ответ:
9763
9763
22.05.2021 12:40

sum = 0

cnt = 0

s = str(input())

while s != "stop" :

   sum += int(s)

   cnt += 1

   s = str(input())

print(sum / cnt)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?