В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
mishakkkk
mishakkkk
22.03.2022 08:24 •  Информатика

Нужно написать программу, где вызывается функция, выводящее первое простое число в указанном диапазоне. Нужно ввести начало и конец диапазона. Если в указанном диапазоне нет ни одного простого числа, программа должнв выдать сообщение There is no prime На языке с++

Ответ:
школа21002100
школа21002100
20.06.2021 15:32

#include <iostream>

#include <cmath>

using namespace std;

bool is_prime_num(int x) {

   for(long long i=2 ; i <= sqrt(x); i++)

 if( x % i == 0)

  return false;

return true;

}

int main()

{

   int arr[10000];

   int n;

   cin >> n; // вводим кол-во элементов массива

   for (int i = 0; i < n; i++)  {

       cin >> arr[i]; // вводим элементы массива n раз

   }

   int a,b;

   cin >> a >> b; // вводим границы диапазона

   int result = 0;

   

   for (int i = a; a < b; i++) {

       if (is_prime_num(arr[i])) {

           result = arr[i];

           break;

       }      

   }

   if ( result == 0) cout << "There is no prime";

   else cout << result;

   return 0;

}

Объяснение:

 Как - то так, если что непонятно - спрашивай

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?