В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ordabaevabayan
ordabaevabayan
09.02.2020 05:30 •  Информатика

Написать программу, которая вычисляет сумму видаs=2/1+3/2+4/3+...+(n+1)/n Найти ошибки в программе

Program A;

var b,c:real;

begin

readln(b);

if b>=0 then c:=23*d

else c:=d*d;

writeln(‘c=’,c)

end.

А) ожидался символ «;»

Б) ошибка в записи выражения

В) неописанный идентификатор

Г) ошибка в записи оператора

Ответ:

Program A;

var b,c:real;

begin

  readln(b);

  if b>=0 then

     c:=23*b

  else

     c:=b*b;

  writeln('c = ', c:0:3);

end.

Правильный код.

Правда у вас есть переменная d, её нет в коде и она не инициализируется, так что я логически заменил её на b

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?