В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
yotuber
yotuber
08.10.2021 18:46 •  Информатика

Python 3 Бинарный поиск
Upper bound
На вход подаются N целых чисел, а также набор из M запросов, каждый из которых — целое число. Ваша задача — для каждого запроса найти количество чисел из исходного набора, меньших либо равных заданному в запросе числу. Использовать встроенные функции бинарного поиска запрещено.

Входные данные

Первая строка содержит число N — количество элементов в массиве. 1≤N≤250000.
Вторая строка содержит N целых чисел Ai через пробел. −109≤Ai≤109.
Третья строка содержит число M — количество запросов. 1≤M≤250000.
Четвёртая строка содержит M целых чисел Qi через пробел. −109≤Qi≤109.

Выходные данные

Выведите единственную строку с M целыми числами — количествами чисел исходного массива, меньших либо равных соответствующему запросу.

Примеры
Ввод
Вывод
5
1 5 3 2 1
2
4 3
4 4

Ответ:
sashacom13
sashacom13
10.06.2021 17:56

n = int(input())

ai = list(map(int, input().split()))

m = int(input())

qi = list(map(int, input().split()))

ai.sort()

for k in range(m):

   i = 0

   j = n - 1

   counter = None

   while i <= j:

       mid = (i + j) // 2

       if qi[k] == ai[mid]:

           counter = mid

           break

       elif qi[k] < ai[mid]:

           j = mid - 1

       else:

           i = mid + 1

           counter = mid

   print(counter + 1, end=' ')

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?