В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
qnorri
qnorri
06.03.2021 08:19 •  Информатика

Напишите программу вычисления выражения на C++:
99 – 98 + 97 – 96 + 95 – 94 + ... + 5 – 4 + 3 – 2 + 1

Ответ:
Тигрица574
Тигрица574
11.05.2021 08:50

99-98+97+96+95-94+6+5-4+3-2+1

а?

0,0(0 оценок)
Ответ:
Зоромдед
Зоромдед
11.05.2021 08:50

#include <iostream>

using namespace std;

signed main() {

int s = 0;

for (int i = 99; i >= 1; i--) {

 if ((i & 1) == 0)

  s -= i;

 else

  s += i;

}

cout << s;

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?