В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 3 и оканчивающихся на 4. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа не превышают 30000. Программа должна вывести одно число: сумму всех натуральных чисел, кратных 3 и оканчивающихся на 4. ​

Ответ:
Leprecon1
Leprecon1
27.04.2021 19:50

program aver;

var s, n, k :integer;

begin

n:= 1; // значение числа для входа в цикл while

s:= 0; // сумма чисел, удовлетворяющих условию

k:= 0; //счетчик чисел

writeln ('Введите серию чисел,');

writeln('заканчивая ввод каждого числа нажатием на Enter');

while (n <> 0) and (k < 1000) do

begin

read(n);

if n > 30000 then

begin

writeln('Число не должно быть больше 30000');

read(n);

end;

if (n mod 10 = 4) and (n mod 6 = 0) then s:= s + n;

k:= k + 1;

end;

writeln('сумма = ', s)

end.

0,0(0 оценок)
Ответ:
матиматик31
матиматик31
27.04.2021 19:50

summ = 0

count = 0

while 1:

   a = int(input())

   if count == 1000: break

   elif a == 0:

       break

   elif a > 30000:

       continue

   count += 1

   if a % 3 == 0 and str(a)[-1] == "4":

       summ += a

print(summ)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?