В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Артем123100
Артем123100
06.11.2022 17:19 •  Информатика

Вопрос 1 Напишите программу на языке Python, которая получает
с клавиатуры натуральное число и определяет
количество цифр в этом числе,
Введите ответ в произвольной форме:
,

Ответ:
voprooos
voprooos
18.04.2021 22:50

Відповідь:

N=int(input())

c=0

while N>0:

   N=N//10

   c=c+1

print(c)

Пояснення:

0,0(0 оценок)
Ответ:
Анастасия73829237
Анастасия73829237
18.04.2021 22:50

i=int(input())

if i<0:

   print(len(str(i))-1)

else:

   print(len(str(i)))

Объяснение:

проверяем положительное ли число, если нет, то из длины символов вычитаем 1 (т.к. у нас "-" считается за символ), иначе выводим просто длину

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?