В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
danilenkoalisk
danilenkoalisk
05.08.2022 19:35 •  Информатика

Написать программу на python, которая по заданным трем числам определяет, является ли сумма каких-либо двух из них положительной

Ответ:
polinavak05
polinavak05
17.05.2021 15:19

begin

var a,b,c,m,n,d: integer;

m:=a+b;

if m:='-m' then begin

showmessage('сумма 1ого и 2ого чисел отрицательна) end else

showmessage ('сумма 1ого и 2ого чисел положительна); end;

n:=a+c;

if n:='-n' then begin

showmessage ('сумма 1ого и 3его числа отрицательна) end else

showmessage ('сумма 1ого и 3его числа положительна); end;

d:=b+c;

if d:='-d' then begin

showmessage ('сумма 2ого и 3его числа отрицательна) end else

showmessage ('сумма 2ого и 3его числа положительна); end;

end.

0,0(0 оценок)
Ответ:
MigelAlemanValdes
MigelAlemanValdes
17.05.2021 15:19

a, b, c = [float(input()) for s in range(3)]

if a + b > 0 or a + c > 0 or b + c > 0:

   print('YES')

else:

   print('NO')

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?