В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
scritinomerok
scritinomerok
11.04.2020 11:53 •  Информатика

Заполнить массив р15 случайными числами и составить программу, которая удвоит элементы меньше !

Ответ:
donik223
donik223
16.05.2021 20:33

Pascal:

var p:array[1..15] of integer;

i:integer;

begin

for i:=1 to 15 do

begin

p[i] := random(31);

if p[i] < 7 then

p[i] := p[i] * 2;

write(p[i], ' ');

end;

end.

Java:

package com.znanija

import java.util.Random;

public class Main {

public static void main(String[] args) {

Random rand = new Random();

int[] p = new int[15];

for (int i=0;i<15;i++) {

p[i] = rand.nextInt(31);

if (p[i] < 7)

p[i] *= 2;

System.out.print(p[i] + " ");

}

}

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?