В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
snejanas1
snejanas1
21.10.2020 17:39 •  Информатика

Составить программу-тренажер «устный счет от 10 до 100», предъявляющую пользователю поочередно примеры на проверку навыков устного счета и проверяющую правильность вычисления пользователем. программа должна выводить на экран произвольные два двузначных числа и знак «+» или «-» между ними. потом пользователь должен ввести свой ответ, а программа проверяет правильность вычислений.

Ответ:
ольга1716
ольга1716
19.06.2020 09:50

Begin

A :=random(100);

B :=random(100);

If 50>random(100) then ch:='+'

Else ch:='-';

Write(a,ch,b);

Read(o);

If (ch='+' and a+b=o) or (ch='-' and a-b=o) then write('ok')

Else write('wrong');

End.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?